EPISODE · Dec 22, 2011
pentacast 41: SASL
from Penta* · host CCC Dresden
In dieser Folge unterhalten sich astro und koeart über einen wichtigen RFC, welcher die Authentifizierung und Autorisierung im Web beschreibt: Den Simple Authentification Security Layer, beschrieben in RFC 4422. Wir erläutern, wie SASL Grundlegend funktioniert, geben ein praktisches Beispiel und erläutern die Anforderungen, welcher der Standard an die Protokolle und Mechanismen stellt. Außerdem vergleichen wir die Mechanismen, und stellen die Vertreter der Verschiedenen Katgeorien vor: Digest, Plain Text, X.509 und - ganz frisch - SCRAM. Shownotes: RFC 4422: SASL WP: HTTP Authentication IANA - Registrierungsseite für Mechanismen RFC 4616: Plain Text Authentifizierung WP: DIGEST/MD5 RFC 5802: SCRAM RFC 5056: Channel Binding WP: TCP/IP Referenz-Schichten Modell WP: TLS WP: XMPP WP: GSSAPI WP: Kerberos GNU SASL Implementation DoveCot SASL Implementation node-xmpp SASL Implementation WP: Kerberos (Zertifikat-basierter Authentifizierungsmechanismus) Pentaradio24: SSL - Screwed Socket Layer CRE172: SSL EFF und SSL WP: OTR Bradley Manning TU Dresden: Semesterticket Umfrage RFC: 4949
Embed this episode
Ready to play
pentacast 41: SASL
No transcript for this episode yet
Similar Episodes
No similar episodes found.